#1 2018-07-12 11:10:46

afktr
Member
Registered: 2018-03-14
Posts: 4

Cant import *gwc or *lib files to Assesment Tool

Hi.
I have a problem with Wasp Engineering, or Assesment tool.
I have a Wasp Engineering project. And i want to use wasp assesment tool.
I have a height, wind, turbine site for assesment tool. Everything is okey.
When i click the button, which says prepare data for WAT, it asks me vector data, generalized wind climate file and generator, right ?
But, there is a problem.
I cant use my *gwc or *lib files.
I open my Wasp project, (not engineering), right click on (IBZ Generalized wind climate), and export ;
When i try to export my generalized wind climate to *lib file, it says "continue, use the choosen format and lose meta-data"
and its really losing ! When i open the file which i exported, there is no temperature, pressure informatiions, and this is very interesting, the location is changes ! For example, lets assume that in Wasp project my location is 56,11.. N and 11,46..E
But It is 11,46..N and 56,11 E in exported *lib file .....

When i try to export my generalized w.c to *gwc file, yes i can export but in Wasp engineering-prepare data for WAT, There is an error.. I cant launch the WAT with gwc file.The Error is :

A problem occurred before the calculations were completed because ... 
    failed to initialise wasp project because ... 
    could not insert a Generalised wind climate to the hierarchy because ... 
    could not restore a wind atlas from file because ... 
    could not load a wind atlas from file because ... 
    could not load a wind climate from a string of XML because ... 
    the system reported that:
    'Invalid use of Null.'

I also tried to use ParqueFicticio's wasp project for generalized wind climate. Also in this project, when i export generalized wind climate to *gwc data, there is an error like above in prepare data for wat.

But i can use Denmark or Waspdale.gwc (in Wasp-misc files)
So, is there a problem with the way which i prepare *gwc or*lib files?
I done everything like in help files, wasp and wasp enginnering...

Offline

#2 2018-07-12 14:20:29

Morten
Administrator
From: DTU Wind Energy
Registered: 2009-11-02
Posts: 129
Website

Re: Cant import *gwc or *lib files to Assesment Tool

Hi,


The ‘Prepare data for WAT tool’ calls some WAsP DLLs to add mean climate predictions (Weibull distributions) to the result table for each turbine site. That is why it asks for a wind atlas file and a map in vector format. The format of the wind atlas file has changed over the years and I suspect that this could be the reason for the problem. I did some experiments and it seems like the WAT launcher tools reads the old LIB format without problems. It also reads a GWC file exported from WAsP 11 correctly but I did not manage to get it to read a GWC file exported from WAsP 12. The GWC format differences are the barometric reference data added in WAsP 12.0 and parameters for the background flow profile added in WAsP 12.1. Since you write about temperature and pressure information, I am guessing that you are in fact using WAsP 12, so your problem is probably related to the modified GWC file format. A work-around solution could be to apply the LIB format instead. If you are worried about the accuracy, then try to compare the Weibull distributions in your WAsP project and the ones which are written in the input file for WAT.


I am not sure about the technical reason for the problem, and I rather not ask the programmer who is on vacation right now. Maybe WEng 4 can only work with the DLLs from WAsP 11 or maybe it gets confused when you, like me, both have WAsP 11 and WAsP 12 installed on the same PC. Anyway, thanks for reporting this. I shall forward the message to the programmers.


Cheers,
Morten

Offline

#3 2018-07-12 15:43:47

afktr
Member
Registered: 2018-03-14
Posts: 4

Re: Cant import *gwc or *lib files to Assesment Tool

Morten wrote:

Hi,


The ‘Prepare data for WAT tool’ calls some WAsP DLLs to add mean climate predictions (Weibull distributions) to the result table for each turbine site. That is why it asks for a wind atlas file and a map in vector format. The format of the wind atlas file has changed over the years and I suspect that this could be the reason for the problem. I did some experiments and it seems like the WAT launcher tools reads the old LIB format without problems. It also reads a GWC file exported from WAsP 11 correctly but I did not manage to get it to read a GWC file exported from WAsP 12. The GWC format differences are the barometric reference data added in WAsP 12.0 and parameters for the background flow profile added in WAsP 12.1. Since you write about temperature and pressure information, I am guessing that you are in fact using WAsP 12, so your problem is probably related to the modified GWC file format. A work-around solution could be to apply the LIB format instead. If you are worried about the accuracy, then try to compare the Weibull distributions in your WAsP project and the ones which are written in the input file for WAT.


I am not sure about the technical reason for the problem, and I rather not ask the programmer who is on vacation right now. Maybe WEng 4 can only work with the DLLs from WAsP 11 or maybe it gets confused when you, like me, both have WAsP 11 and WAsP 12 installed on the same PC. Anyway, thanks for reporting this. I shall forward the message to the programmers.


Cheers,
Morten

Hi Morten

Thanks for your quick answer.

Now, I made a project with Wasp 11.6, and i exported *gwc file.
And it works :)
Like you said, my problem related to Wasp version.

Offline

Board footer

Powered by FluxBB